或阿呆のブログ

Pythonを好んで使っているプログラマです。Ruby,Perl,PowerShell,VBAなどでもたまに書いています。おバカなことが大好きです。

pipのインストール

scrapyをインストールしたくて、pipかeasy_installが必要なのでpipを選びました。

pipのほうが後発だけれども主流になりつつあるからですかね。あと、easy_installっていかにも気持ち悪い。コマンドに_(アンダーバー)つけるのがPythonっぽくないと思います。

pipはPythonで書かれたパッケージソフトウェアをインストール・管理するためのパッケージ管理システムである。多くのPythonパッケージは、Python Package Index(PyPI)上にある[1]。
pip - Wikipedia

どちらもインストールしろよって話ですけどねw

$sudo apt-get install python-pip
[sudo] password for oneshotlife_tom: 
パッケージリストを読み込んでいます... 完了
依存関係ツリーを作成しています                
状態情報を読み取っています... 完了
以下の特別パッケージがインストールされます:
  python-colorama python-distlib python-html5lib python-requests
  python-setuptools python-urllib3
提案パッケージ:
  python-genshi
推奨パッケージ:
  build-essential python-dev-all
以下のパッケージが新たにインストールされます:
  python-colorama python-distlib python-html5lib python-pip python-requests
  python-setuptools python-urllib3
アップグレード: 0 個、新規インストール: 7 個、削除: 0 個、保留: 306 個。
623 kB のアーカイブを取得する必要があります。
この操作後に追加で 2,925 kB のディスク容量が消費されます。
続行しますか? [Y/n] y
取得:1 http://archive.ubuntu.com/ubuntu/ trusty/universe python-colorama all 0.2.5-0.1ubuntu1 [18.3 kB]
取得:2 http://archive.ubuntu.com/ubuntu/ trusty/universe python-distlib all 0.1.8-1 [113 kB]
取得:3 http://archive.ubuntu.com/ubuntu/ trusty/main python-html5lib all 0.999-2 [83.2 kB]
取得:4 http://archive.ubuntu.com/ubuntu/ trusty/main python-setuptools all 3.3-1ubuntu1 [230 kB]
取得:5 http://archive.ubuntu.com/ubuntu/ trusty/main python-urllib3 all 1.7.1-1build1 [38.9 kB]
取得:6 http://archive.ubuntu.com/ubuntu/ trusty/main python-requests all 2.2.1-1 [42.5 kB]
取得:7 http://archive.ubuntu.com/ubuntu/ trusty/universe python-pip all 1.5.4-1 [97.7 kB]
623 kB を 17秒 で取得しました (35.3 kB/s)                                      
以前に未選択のパッケージ python-colorama を選択しています。
(データベースを読み込んでいます ... 現在 167200 個のファイルとディレクトリがインストールされています。)
Preparing to unpack .../python-colorama_0.2.5-0.1ubuntu1_all.deb ...
Unpacking python-colorama (0.2.5-0.1ubuntu1) ...
以前に未選択のパッケージ python-distlib を選択しています。
Preparing to unpack .../python-distlib_0.1.8-1_all.deb ...
Unpacking python-distlib (0.1.8-1) ...
以前に未選択のパッケージ python-html5lib を選択しています。
Preparing to unpack .../python-html5lib_0.999-2_all.deb ...
Unpacking python-html5lib (0.999-2) ...
以前に未選択のパッケージ python-setuptools を選択しています。
Preparing to unpack .../python-setuptools_3.3-1ubuntu1_all.deb ...
Unpacking python-setuptools (3.3-1ubuntu1) ...
以前に未選択のパッケージ python-urllib3 を選択しています。
Preparing to unpack .../python-urllib3_1.7.1-1build1_all.deb ...
Unpacking python-urllib3 (1.7.1-1build1) ...
以前に未選択のパッケージ python-requests を選択しています。
Preparing to unpack .../python-requests_2.2.1-1_all.deb ...
Unpacking python-requests (2.2.1-1) ...
以前に未選択のパッケージ python-pip を選択しています。
Preparing to unpack .../python-pip_1.5.4-1_all.deb ...
Unpacking python-pip (1.5.4-1) ...
Processing triggers for man-db (2.6.7.1-1) ...
python-colorama (0.2.5-0.1ubuntu1) を設定しています ...
python-distlib (0.1.8-1) を設定しています ...
python-html5lib (0.999-2) を設定しています ...
python-setuptools (3.3-1ubuntu1) を設定しています ...
python-urllib3 (1.7.1-1build1) を設定しています ...
python-requests (2.2.1-1) を設定しています ...
python-pip (1.5.4-1) を設定しています ...