或阿呆のブログ

Pythonを好んで使っているプログラマです。Ruby,Perl,PowerShell,VBAなどでもたまに書いています。おバカなことが大好きです。

LinuxMint17にnokogiriインストール手こずったぞ~ #nokogiri #LinuxMint17

nokogiriは依存関係が複雑過ぎる。。。あと最新のものになればなるほど、情報が錯乱しててダメだわ・・・。

$sudo apt-get -yV install ruby-full
$sudo apt-get -yV install ruby1.9.1-full
$sudo apt-get -yV install rubygems
$sudo gem install rubygems-update
$sudo gem1.9.1 install rubygems-update
$sudo apt-get install ruby-dev ruby ri rdoc irb
$sudo apt-get install libruby

これあたりやって、nokogiriをバージョン指定するといけた。

$sudo gem install nokogiri -v '1.5.2'  -- --with-cflags=\"-O2 -pipe -march=native -w\"